Project

General

Profile

Actions

Bug #892

closed

Two questions about sendmail(8)

Added by frank about 16 years ago. Updated about 15 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I have encountered unexpected difficulties with sendmail (on both HEAD and
1_10_Slip). Possibly I have missed something new, I'm not sure if all this
is a bug. First, is the well-known method to rebuild sendmail, i.e.,

cd /usr/src/usr.sbin/sendmail
make cleandir
make obj
make

still supposed to work? If so, there is problem linking the binary:
---
cc: /usr/src/lib/libsmutil/libsmutil.a: No such file or directory
  • Error code 1

Stop in /usr/src/usr.sbin/sendmail.
---

Secondly, sendmail 8.14.x refuses connections from hosts in the local net.
Messages from localhost are processed normally, but a connection from a
remote host only gives a syslog message like this:
---
Dec 20 18:19:00 <hostname> kernel: pid 63229 (sendmail), uid 0: exited on signal 11
---
For example, it is sufficient to do a 'nc -z <hostname> 25' on a remote
machine to get this. The same can be observed for sendmail 8.14.2 from
pkgsrc. On the other hand, sendmail 8.13.8 (from pkgsrc) with the the
identical(!) mailer configuration has no problems at all and shows normal
operation. Any idea what's going wrong here?

Regards,
Frank Josellis

Actions #1

Updated by swildner about 16 years ago

It seems that sendmail needs lib/libsm and lib/libsmutil built previously.

Sascha

Actions #2

Updated by frank about 16 years ago

What make me curious is that these libs are apparently expected to be
found under /usr/src/..., not /usr/obj/... The path looks strange to me.

Regards,
Frank

Actions #3

Updated by swildner about 16 years ago

Hmm,

I just tried.

The following sequence works here:

cd /usr/src/lib/libsm
make obj
make
cd ../libsmutil
make obj
make
cd ../../usr.sbin/sendmail
make obj
make

Sascha

Actions #4

Updated by frank about 16 years ago

Having again the possibility to rebuild sendmail, I could do another test.
On the 1.10 box I had 'CCVER?=gcc41' set in /etc/make.conf, and this has
now been reset to the default. The sendmail 18.4.1 excutable built with
gcc 3.4.6 doesn't show the described behavior and relays my mail just as
desired. So the compiler is apparently involved.

Regards,
Frank

Actions #5

Updated by hasso about 15 years ago

Is it still the case?

Actions #6

Updated by frank about 15 years ago

On Tue, 20 Jan 2009, Hasso Tepper (via DragonFly issue tracker) wrote:

No, it's solved. As far as I remember some sendmail fixes were committed
in early 2008, and the signal 11 + coredump issue I had observed was
obviously a related to this.

Regards,
Frank Josellis

Actions #7

Updated by swildner about 15 years ago

Problem solved according to OP.

Actions #8

Updated by swildner about 15 years ago

close

Actions

Also available in: Atom PDF