Bug #1083

dfly-2.0.0-REL: panic: hammer: insufficient undo FIFO space!

Added by mk almost 6 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

OS: dfly-2.0.0-REL

I backed up my 5GB win2k ntfs partition to a disk image file on my Hammer FS
(6GB in size). When removing the image file, panic occurs.

To reproduce panic:

NOTE: assuming Hammer FS is mounted on /hammer dir and /root is symlinked to
/hammer/root.

# cd /root
# cat /dev/ad0s1 > c.img
# rm c.img
PANIC

Screen Shot of Panic: http://www.bmk.com.au/webshare/hammer_panic.jpg

My dmesg: http://www.bmk.com.au/webshare/dmesg.txt

My fdisk, disklabel & fstab: http://www.bmk.com.au/webshare/labels.txt

History

#1 Updated by dillon almost 6 years ago

:OS: dfly-2.0.0-REL
:
:I backed up my 5GB win2k ntfs partition to a disk image file on my Hammer FS
:(6GB in size). When removing the image file, panic occurs.
:
:To reproduce panic:
:
:NOTE: assuming Hammer FS is mounted on /hammer dir and /root is symlinked to
:/hammer/root.
:
:# cd /root
:# cat /dev/ad0s1 > c.img
:# rm c.img
: PANIC

Ok, I'm on it. It's probably due to the tiny undo fifo one gets
when one has a tiny 6GB filesystem.

-Matt
Matthew Dillon
<>

#2 Updated by bastyaelvtars almost 6 years ago

On Wed, 23 Jul 2008 11:05:06 -0700 (PDT)
Matthew Dillon <> wrote:

This is strange. I have my 4gig /usr on HAMMER and did not have such
panics.

#3 Updated by bastyaelvtars over 4 years ago

correction: I am also experiencing this on 2.4.1 and did so on 2.4.0. Has not
happened before.

#4 Updated by mk over 4 years ago

Yes, that's because the installer uses "-f" on the the newfs_hammer command.

By doing this, they have disabled the feature that protects us from a
too small undo FIFO.

Gergo Szakal (via DragonFly issue tracker) wrote:
> Gergo Szakal <> added the comment:
>
> correction: I am also experiencing this on 2.4.1 and did so on 2.4.0. Has not
> happened before.
>
> _____________________________________________________
> DragonFly issue tracker <>
> <http://bugs.dragonflybsd.org/issue1083>
> _____________________________________________________
>

#5 Updated by ftigeot over 2 years ago

  • Description updated (diff)
  • Status changed from New to Resolved

A warning saying smaller than 10GB HAMMER filesystems are unsupported has been added to the installer.

#6 Updated by ftigeot over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (0)

Also available in: Atom PDF