Bug #1465

gdb does not remove breakpoints on detach

Added by corecode over 5 years ago. Updated 10 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:tuxillo% Done:

0%

Category:Userland
Target version:3.8.0

Description

how to reproduce:

% sleep 100 &
[1] 4279
% gdb sleep 4279
GNU gdb 6.7.1
Copyright (C) 2007 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-dragonfly"...
Attaching to program: /bin/sleep, process 4279
0x0804900f in nanosleep () at nanosleep.S:2
2 RSYSCALL(nanosleep)
(gdb) n
^C
Program received signal SIGINT, Interrupt.
0x0804900f in nanosleep () at nanosleep.S:2
2 RSYSCALL(nanosleep)
Current language: auto; currently asm
(gdb) q
The program is running. Quit anyway (and detach it)? (y or n) y
Detaching from program: /bin/sleep, process 4279
[1] + trace trap (core dumped) sleep 100

signature.asc Magnifier (901 Bytes) corecode, 02/22/2014 01:21 PM

History

#1 Updated by tuxillo 10 months ago

  • Description updated (diff)
  • Category set to Userland
  • Assignee changed from 0 to tuxillo
  • Target version set to 3.8.0

Grab.

#2 Updated by tuxillo 10 months ago

  • Status changed from New to Feedback

Hi,

Can't reproduce:

antonioh@nas:~$ gdb sleep 1488
GNU gdb (GDB) 7.6.1
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-dragonfly".
For bug reporting instructions, please see:
<http://bugs.dragonflybsd.org/&gt;...
Reading symbols from /bin/sleep...(no debugging symbols found)...done.
Attaching to program: /bin/sleep, process 1488
0x0000000000400b44 in ?? ()
(gdb) cont
Continuing.
^C
Program received signal SIGINT, Interrupt.
0x0000000000400b44 in ?? ()
(gdb) quit
A debugging session is active.

Inferior 1 [process 1488] will be detached.

Quit anyway? (y or n) yes
Detaching from program: /bin/sleep, process 1488
[1] + Done sleep 100

Cheers,
Antonio Huete

#3 Updated by corecode 10 months ago

Perfect!

On 02/22/2014 07:05 PM, wrote:
> Issue #1465 has been updated by tuxillo.
>
> Status changed from New to Feedback
>
> Hi,
>
> Can't reproduce:
>
> antonioh@nas:~$ gdb sleep 1488
> GNU gdb (GDB) 7.6.1
> Copyright (C) 2013 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law. Type "show copying"
> and "show warranty" for details.
> This GDB was configured as "x86_64-dragonfly".
> For bug reporting instructions, please see:
> <http://bugs.dragonflybsd.org/&gt;...
> Reading symbols from /bin/sleep...(no debugging symbols found)...done.
> Attaching to program: /bin/sleep, process 1488
> 0x0000000000400b44 in ?? ()
> (gdb) cont
> Continuing.
> ^C
> Program received signal SIGINT, Interrupt.
> 0x0000000000400b44 in ?? ()
> (gdb) quit
> A debugging session is active.
>
> Inferior 1 [process 1488] will be detached.
>
> Quit anyway? (y or n) yes
> Detaching from program: /bin/sleep, process 1488
> [1] + Done sleep 100
>
> Cheers,
> Antonio Huete
>
>
> ----------------------------------------
> Bug #1465: gdb does not remove breakpoints on detach
> http://bugs.dragonflybsd.org/issues/1465#change-11824
>
> * Author: corecode
> * Status: Feedback
> * Priority: Normal
> * Assignee: tuxillo
> * Category: Userland
> * Target version: 3.8.0
> ----------------------------------------
> how to reproduce:
>
> % sleep 100 &
> [1] 4279
> % gdb sleep 4279
> GNU gdb 6.7.1
> Copyright (C) 2007 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law. Type "show copying"
> and "show warranty" for details.
> This GDB was configured as "i386-dragonfly"...
> Attaching to program: /bin/sleep, process 4279
> 0x0804900f in nanosleep () at nanosleep.S:2
> 2 RSYSCALL(nanosleep)
> (gdb) n
> ^C
> Program received signal SIGINT, Interrupt.
> 0x0804900f in nanosleep () at nanosleep.S:2
> 2 RSYSCALL(nanosleep)
> Current language: auto; currently asm
> (gdb) q
> The program is running. Quit anyway (and detach it)? (y or n) y
> Detaching from program: /bin/sleep, process 4279
> [1] + trace trap (core dumped) sleep 100
>
>
>

#4 Updated by tuxillo 10 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF