Project

General

Profile

Bug #1802

AHCI timeouts on SMP APIC_IO system

Added by alexh over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%


Description

When running an SMP kernel with APIC_IO on my ThinkPad T60, AHCI times out as
shown in the images below. I'm running master from about 8 hours ago.
http://leaf.dragonflybsd.org/~alexh/ahci1.jpg
http://leaf.dragonflybsd.org/~alexh/ahci2.jpg
http://leaf.dragonflybsd.org/~alexh/ahci3.jpg
http://leaf.dragonflybsd.org/~alexh/ahci4.jpg

History

#1 Updated by dillon about 6 years ago

:New submission from Alex Hornung <>:
:
:When running an SMP kernel with APIC_IO on my ThinkPad T60, AHCI times out as
:shown in the images below. I'm running master from about 8 hours ago.
:http://leaf.dragonflybsd.org/~alexh/ahci1.jpg
:http://leaf.dragonflybsd.org/~alexh/ahci2.jpg
:http://leaf.dragonflybsd.org/~alexh/ahci3.jpg
:http://leaf.dragonflybsd.org/~alexh/ahci4.jpg

Looks like interrupt routing, meaning it might not work with APIC_IO
but might work without, or with/without ACPI (which is the problem I
am having on my test box).

You can also try running with the emergency interrupt polling enabled
to see if that allows the system to boot. It isn't a solution but it
will verify what the problem is.

-Matt
Matthew Dillon
<>

#2 Updated by alexh about 6 years ago

works without APIC_IO.

Also available in: Atom PDF