Bug #2718

usbd_enable="yes" in /etc/rc.conf can cause a server to be unable to reboot without manual intervention

Added by zcrownover 3 months ago. Updated 3 months ago.

Status:NewStart date:08/22/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:3.8.0

Description

I installed 3.8.2 from a CD on a server the day before yesterday, the default /etc/rc.conf that came with it, modified initially by me only for the networking setup, had usbd_enable="yes" in it. When I tried to reboot, after stopping sshd but before getting to devd, it just stopped. I came back in person the next morning and just hit ctrl-alt-delete, and it resumed the reboot process and booted up normally. I changed the usbd_enable="yes" to no, and that fixed the problem.

i don't know if this affects all hardware or just the supermicro I ran this on, but unless you have physical/ipmi access to a system, this would make reboots impossible remotely.

History

#1 Updated by swildner 3 months ago

Does the box have /usr/sbin/usbd?

It should only exist on systems compiled with WANT_OLDUSB but not for usb4bsd which is the default. The /etc/rc.d/usbd script has a check so it will do its thing only if /usr/sbin/usbd exists and thus be a no-op on default usb4bsd systems.

#2 Updated by zcrownover 3 months ago

> ls /usr/sbin/u*
/usr/sbin/usbconfig /usr/sbin/usbdump

No. This was with the stock kernel in the 3.8.2 ISO. I have updated it since changing the usbd_enable="no". I pulled the source and compiled with the default configuration options.

Also available in: Atom PDF