Project

General

Profile

Bug #2896

acpi update received - kernel unbootable

Added by arcade@b1t.name over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
ACPI
Target version:
-
Start date:
03/23/2016
Due date:
% Done:

100%


Description

After recent acpi update kernel hangs when initializing HPET timer. Screenshot attached.

History

#1 Updated by swildner over 1 year ago

  • Assignee set to swildner

grab

#2 Updated by swildner over 1 year ago

The acpi_hpet issue looks like some followup issue from an acpi_timer issue earlier in the boot. A quick workaround would be to put

debug.acpi.disabled="timer"

into loader.conf.

But before that, can you try this patch -> https://leaf.dragonflybsd.org/~swildner/0001-kernel-acpi_timer-\
Add-a-missing-cpu_enable_intr-afte.patch ? My hopes are not very high regarding the patch, though.

I will try to reproduce it locally.

#4 Updated by arcade@b1t.name over 1 year ago

Workaround works, patch doesn't (after quickkernel, rebuilding now kernel from scratch to retest).

dmesg:

Copyright (c) 2003-2016 The DragonFly Project.
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
DragonFly 30e6a97-DEVELOPMENT #5: Tue Mar 22 17:29:20 EET 2016
arcade@probe:/usr/obj/usr/src/sys/MINIMAL
TSC invariant clock: 3193018760 Hz, i8254 clock: 1193169 Hz
CPU: AMD A8-5500 APU with Radeon(tm) HD Graphics (3193.07-MHz K8-class CPU)
Origin = "AuthenticAMD" Id = 0x610f01 Stepping = 1
Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
Features2=0x3698320b<SSE3,PCLMULQDQ,MON,SSSE3,FMA,CX16,SSE4.1,SSE4.2,POPCNT,AESNI,XSAVE,AVX,F16C>
AMD Features=0x2e500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM>
AMD Features2=0x1ebbfff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,XOP,SKINIT,WDT,LWP,FMA4,TCE,NodeId,TBM,Topology,PCX_CORE,PCX_NB>
Structured Extended Features=0x8<BMI1>
MONITOR/MWAIT Features=0x2<INTBRK>
real memory = 7732201472 (7374 MB)
avail memory = 7202357248 (6868 MB)
LAPIC: AMD LINTEN on
lapic: divisor index 0, frequency 49891605 Hz
Initialize MI interrupts
link_elf_obj_obj: symbol md_mount undefined
KLD file nfs.ko - could not finalize loading
Compute unit iDS:
0-0;
1-0;
2-1;
3-1;
wdog: In-kernel automatic watchdog reset enabled
md0: Malloc disk
kbd1 at kbdmux0
ACPI: RSDP 0x00000000000F04A0 000024 (v02 ALASKA)
ACPI: XSDT 0x000000008DBC9078 00006C (v01 ALASKA A M I 01072009 AMI 00010013)
ACPI: FACP 0x000000008DBCF2A8 00010C (v05 ALASKA A M I 01072009 AMI 00010013)
ACPI BIOS Warning (bug): Optional FADT field Pm2ControlBlock has valid Length but zero Address: 0x0000000000000000/0x1 (20160318/tbfadt-684)
ACPI: DSDT 0x000000008DBC9178 00612B (v02 ALASKA A M I 00000000 INTL 20051117)
ACPI: FACS 0x000000008DBD1080 000040
ACPI: APIC 0x000000008DBCF3B8 000072 (v03 ALASKA A M I 01072009 AMI 00010013)
ACPI: FPDT 0x000000008DBCF430 000044 (v01 ALASKA A M I 01072009 AMI 00010013)
ACPI: MCFG 0x000000008DBCF478 00003C (v01 ALASKA A M I 01072009 MSFT 00010013)
ACPI: HPET 0x000000008DBCF4B8 000038 (v01 ALASKA A M I 01072009 AMI 00000005)
ACPI: IVRS 0x000000008DBCF4F0 000070 (v02 AMD ANNAPURN 00000001 AMD 00000000)
ACPI: SSDT 0x000000008DBCF560 000D40 (v01 AMD ANNAPURN 00000001 AMD 00000001)
ACPI: SSDT 0x000000008DBD02A0 0004B7 (v02 AMD ANNAPURN 00000001 MSFT 04000000)
ACPI: CRAT 0x000000008DBD0758 0002A8 (v01 AMD ANNAPURN 00000001 AMD 00000001)
acpi0: <ALASKA A M I> on motherboard
ACPI: Executed 1 blocks of module-level executable AML code
ACPI: 3 ACPI AML tables successfully acquired and loaded
ACPI FADT: SCI testing interrupt mode ...
ACPI FADT: SCI select level/low
objcache_reclaimlist
objcache_reclaimlist
objcache_reclaimlist
objcache_reclaimlist
acpi0: Power Button (fixed)
acpi_timer0 on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Copyright (c) 2003-2016 The DragonFly Project.
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
DragonFly 30e6a97-DEVELOPMENT #5: Tue Mar 22 17:29:20 EET 2016
arcade@probe:/usr/obj/usr/src/sys/MINIMAL
TSC invariant clock: 3193034985 Hz, i8254 clock: 1193175 Hz
CPU: AMD A8-5500 APU with Radeon(tm) HD Graphics (3193.07-MHz K8-class CPU)
Origin = "AuthenticAMD" Id = 0x610f01 Stepping = 1
Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
Features2=0x3698320b<SSE3,PCLMULQDQ,MON,SSSE3,FMA,CX16,SSE4.1,SSE4.2,POPCNT,AESNI,XSAVE,AVX,F16C>
AMD Features=0x2e500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM>
AMD Features2=0x1ebbfff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,XOP,SKINIT,WDT,LWP,FMA4,TCE,NodeId,TBM,Topology,PCX_CORE,PCX_NB>
Structured Extended Features=0x8<BMI1>
MONITOR/MWAIT Features=0x2<INTBRK>
real memory = 7732201472 (7374 MB)
avail memory = 7204839424 (6871 MB)
LAPIC: AMD LINTEN on
lapic: divisor index 0, frequency 49891610 Hz
Initialize MI interrupts
link_elf_obj_obj: symbol md_mount undefined
KLD file nfs.ko - could not finalize loading
Compute unit iDS:
0-0;
1-0;
2-1;
3-1;
wdog: In-kernel automatic watchdog reset enabled
kbd1 at kbdmux0
ACPI: RSDP 0x00000000000F04A0 000024 (v02 ALASKA)
ACPI: XSDT 0x000000008DBC9078 00006C (v01 ALASKA A M I 01072009 AMI 00010013)
ACPI: FACP 0x000000008DBCF2A8 00010C (v05 ALASKA A M I 01072009 AMI 00010013)
ACPI BIOS Warning (bug): Optional FADT field Pm2ControlBlock has valid Length but zero Address: 0x0000000000000000/0x1 (20160318/tbfadt-684)
ACPI: DSDT 0x000000008DBC9178 00612B (v02 ALASKA A M I 00000000 INTL 20051117)
ACPI: FACS 0x000000008DBD1080 000040
ACPI: APIC 0x000000008DBCF3B8 000072 (v03 ALASKA A M I 01072009 AMI 00010013)
ACPI: FPDT 0x000000008DBCF430 000044 (v01 ALASKA A M I 01072009 AMI 00010013)
ACPI: MCFG 0x000000008DBCF478 00003C (v01 ALASKA A M I 01072009 MSFT 00010013)
ACPI: HPET 0x000000008DBCF4B8 000038 (v01 ALASKA A M I 01072009 AMI 00000005)
ACPI: IVRS 0x000000008DBCF4F0 000070 (v02 AMD ANNAPURN 00000001 AMD 00000000)
ACPI: SSDT 0x000000008DBCF560 000D40 (v01 AMD ANNAPURN 00000001 AMD 00000001)
ACPI: SSDT 0x000000008DBD02A0 0004B7 (v02 AMD ANNAPURN 00000001 MSFT 04000000)
ACPI: CRAT 0x000000008DBD0758 0002A8 (v01 AMD ANNAPURN 00000001 AMD 00000001)
acpi0: <ALASKA A M I> on motherboard
ACPI: Executed 1 blocks of module-level executable AML code
ACPI: 3 ACPI AML tables successfully acquired and loaded
ACPI FADT: SCI testing interrupt mode ...
ACPI FADT: SCI select level/low
objcache_reclaimlist
objcache_reclaimlist
objcache_reclaimlist
objcache_reclaimlist
acpi0: Power Button (fixed)
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
acpi_hpet0: frequency 14318180
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <base peripheral> (vendor 0x1022, dev 0x1419) at device 0.2 irq 16
vgapci0: <VGA-compatible display> port 0xf000-0xf0ff mem 0xfef00000-0xfef3ffff,0xc0000000-0xcfffffff irq 17 at device 1.0 on pci0
vgapci0: Boot video device
pci0: <multimedia, HDA> (vendor 0x1002, dev 0x9902) at device 1.1 irq 18
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 4.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <network, ethernet> (vendor 0x10ec, dev 0x8168) at device 0.0 irq 16

#5 Updated by arcade@b1t.name over 1 year ago

  • File deleted (IMG_20160323_200603.jpg)

#6 Updated by swildner over 1 year ago

I've reverted the ACPICA upgrade in master for now.

#7 Updated by swildner over 1 year ago

I think it should be fixed now in master.

Can you re-test without the debug.acpi.disabled="timer" in loader.conf?

#8 Updated by arcade@b1t.name over 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Works for me now. Thanks.

Also available in: Atom PDF