Project

General

Profile

Bug #3054

Xorg hangs on cstp1 after recent hammer2 changes (working on hammer2).

Added by arcade@b1t.name 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Kernel
Target version:
-
Start date:
08/28/2017
Due date:
% Done:

0%


Description

Well as hammer2 recently was made much cozier I moved there (due to errors on hammer disk and corrupted files). After that right now I see Xorg hanging on cstp1 when someone under Xorg is doing 3d graphics. 2d graphics doesn't count and host is stable. Not using Xorg doesn't count and host is stable. During hang there is still a possibility of recovering sometimes and Xorg can be restarted. When Xorg hangs all host is still resposive and works as intended.

History

#1 Updated by sepherosa 3 months ago

There are several callout changes; if you caught in the middle,
something may happen. Are you using the latest master?

On Tue, Aug 29, 2017 at 2:03 AM,
<> wrote:
> Issue #3054 has been reported by .
>
> ----------------------------------------
> Bug #3054: Xorg hangs on cstp1 after recent hammer2 changes (working on hammer2).
> http://bugs.dragonflybsd.org/issues/3054
>
> * Author:
> * Status: New
> * Priority: Normal
> * Assignee:
> * Category: Kernel
> * Target version:
> ----------------------------------------
> Well as hammer2 recently was made much cozier I moved there (due to errors on hammer disk and corrupted files). After that right now I see Xorg hanging on cstp1 when someone under Xorg is doing 3d graphics. 2d graphics doesn't count and host is stable. Not using Xorg doesn't count and host is stable. During hang there is still a possibility of recovering sometimes and Xorg can be restarted. When Xorg hangs all host is still resposive and works as intended.
>
>
>
> --
> You have received this notification because you have either subscribed to it, or are involved in it.
> To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

--
Tomorrow Will Never Die

#2 Updated by arcade@b1t.name 3 months ago

Yes, now rebuilding to latest changes on master. The only exception is: I reverted back all changes from #3031 as they are keep crashing my PC on drm init.

#3 Updated by arcade@b1t.name 3 months ago

Freezed on ttmfence this time.

#4 Updated by arcade@b1t.name 2 months ago

  • Status changed from New to Closed

Doesn't happen in a while, probably fixed already.

Also available in: Atom PDF