Project

General

Profile

Bug #3081

Cannot install npm package eslint

Added by ollehar about 1 month ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Userland
Target version:
-
Start date:
10/15/2017
Due date:
% Done:

0%


Description

When trying to install the npm package eslint, I get the following error:

1091 verbose stack Error
1091 verbose stack at /usr/local/lib/node_modules/npm/lib/utils/gently-rm.js:275:7
1091 verbose stack at /usr/local/lib/node_modules/npm/node_modules/iferr/index.js:13:50
1091 verbose stack at /usr/local/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:287:18
1091 verbose stack at FSReqWrap.oncomplete (fs.js:153:5)
1092 verbose cwd /root/.npm/_logs
1093 verbose DragonFly 4.8-RELEASE
1094 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "i" "-g" "npm"
1095 verbose node v8.4.0
1096 verbose npm v5.3.0
1097 error code EINVAL
1098 error EINVAL: invalid argument, read
1099 verbose exit [ 1, true ]

Not sure how to debug more. I've also post this bug on github npm page: https://github.com/npm/npm/issues/18848

To reproduce:

1. Fresh installation of dfly 4.8-RELEASE
2. pkg install node npm
3. As root, npm install -g eslint

History

#1 Updated by mneumann about 1 month ago

You could try ```yarn```. I also had problems with ```npm``` on DragonFly and now use ```yarn``` [with success][1].

[1]: https://www.ntecs.de/blog/2017-08-10-developing-mobile-apps-on-dragonfly-with-react-native/

Also available in: Atom PDF