Bug #496

flex upgrade

Added by pavalos almost 8 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:dragonflybsd1% Done:

0%

Category:-
Target version:-

Description

So here's a patch that will bring in the latest version of flex, and will
put it in contrib/. I'd appreciate some feedback. If I don't hear any
objections, I'll plan on importing this in about a week.

http://www.theshell.com/~pavalos/wip/lex.patch

Another possible thing we could do is move the library building into
lib/libln/. What do you think about that?

Thanks,
Peter

History

#1 Updated by pavalos almost 8 years ago

Forgot to mention that this depends on changes to m4:
http://leaf.dragonflybsd.org/mailarchive/submit/2006-12/msg00036.html

#2 Updated by pavalos almost 8 years ago

I've decided to postpone this upgrade until after the next release to test
the impact on 3rd-party programs. Here's the NEWS file for flex for people
to see the user-visible changes:

http://flex.cvs.sourceforge.net/flex/flex/NEWS?view=markup

--Peter

#3 Updated by corecode almost 8 years ago

is that necessary? what do we gain from a new version? it seems that this breaks code in world (see your amd patch). this leads me to the conclusion that it might break 3rd party code as well. i think this should only go into the tree after massive testing of pkgsrc etc.

cheers
simon

#4 Updated by marino almost 2 years ago

  • Description updated (diff)
  • Status changed from New to In Progress
  • Assignee changed from pavalos to dragonflybsd1
  • Priority changed from Low to Normal

I'll take this.
We now have the opposite problem; lex is so old s/w doesn't build on it anymore. pkgsrc has been masking this for a while, especially with their new FLEX_REQD directive.

#5 Updated by marino almost 2 years ago

I tried to upgrade flex, but it turns out that our M4 isn't working right (confirmed by dports that was using new flex with system M4 before I changed it to use GM4).

So first I have to up to update M4 before importing Flex. It will have to be done in stages.

#6 Updated by pavalos almost 2 years ago

m4 updated in 4afad3d8f675d4c7d767e86520a3c2eda3d56658.

#7 Updated by marino almost 2 years ago

Thanks.
The latest version of flex builds entire world now (with a bug fix to contrib/amd/amd) so I will be committing this very soon!

#8 Updated by marino almost 2 years ago

flex 2.5.37 is in master.
I left lex in place (not building), I will remove in about a week or so.

#9 Updated by marino over 1 year ago

  • Status changed from In Progress to Closed

legacy lex files now removed.

Also available in: Atom PDF