Bug #760

SCSI RAID controller not recognized

Added by rumcic over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

After updating from 1.9.0-PREVIEW (from May ~10th), my RAID controller is not
recognized anymore (I only use it as a normal SCSI controller, since the onboard
controllers are problematic and dfly doesn't support RAID functionality of that
card).

With the old kernel, it is recognized as:
ahc0: <Adaptec 398X Ultra SCSI RAID adapter> port 0xa000-0xa0ff mem
0x11200000-0x11200fff irq 12 at device 4.0 on pci2
aic7880: Ultra Wide Channel A, SCSI Id=7, 16/253 SCBs
ahc1: <Adaptec aic7815 RAID memory controller> port 0xa400-0xa4ff mem
0x11800000-0x11bfffff,0x11201000-0x11201fff irq 12 at device 8.0 on pci2
RAID functionality unsupported
device_probe_and_attach: ahc1 attach returned 6

History

#1 Updated by dillon over 6 years ago

:New submission from Rumko <>:
:
:After updating from 1.9.0-PREVIEW (from May ~10th), my RAID controller is n=
:ot
:recognized anymore (I only use it as a normal SCSI controller, since the on=
:board
:controllers are problematic and dfly doesn't support RAID functionality of =
:that
:card).
:
:With the old kernel, it is recognized as:
:ahc0: <Adaptec 398X Ultra SCSI RAID adapter> port 0xa000-0xa0ff mem

A fix will probably not make it into the release but please post
pciconf -l output with the old kernel AND with the new kernel.

-Matt

#2 Updated by rumcic over 6 years ago

ahc0@pci2:4:0: class=0x010000 card=0x78839004 chip=0x83789004 rev=0x01 hdr=0x00

I can't get the pciconf output with the new kernel, because the machine can't
boot (all the drives are on that controller) and the cd-rom is broken (whenever
i close the tray, a few seconds later it opens it again ... the only "spare"
drive is in my workstation which i don't want to disassemble unless its really
really necessary).

#3 Updated by rumcic over 6 years ago

http://www.rumko.net/dragonfly/boot
I put the pictures of the verbose boot process in that directory.

#4 Updated by dillon over 6 years ago

:Rumko <> added the comment:
:
:ahc0@pci2:4:0: class=3D0x010000 card=3D0x78839004 chip=3D0x83789004 rev=3D=
:0x01 hdr=3D0x00
:
:I can't get the pciconf output with the new kernel, because the machine can=
:'t
:boot (all the drives are on that controller) and the cd-rom is broken (when=
:ever
:i close the tray, a few seconds later it opens it again ... the only "spare"
:drive is in my workstation which i don't want to disassemble unless its rea=
:lly
:really necessary).

I think I found the issue. For some reason AHC_PCI_CONFIG needs to be
defined and it isn't. I am going to commit a fix right (i.e. remove
the need to define AHC_PCI_CONFIG).

-Matt

#5 Updated by rumcic over 6 years ago

That was it, this bug has been fixed, thank you :)

Also available in: Atom PDF