Project

General

Profile

Actions

Bug #1887

closed

System freezes with syscons screen saver on and a high CPU load

Added by steve over 11 years ago. Updated 3 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Hi,

I'm running v2.9.0.68.g57eab-DEVELOPMENT on an M4A78L motherboard with a Phenom II 955 (quad core 3.2 GHz), however this has been happening for a while but it's only now that I've pinned down the circumstances.

If I have the logo-saver running and displayed on the console then anything that generates a high CPU load (make -j 8 buildworld in an ssh session from another box does nicely) will lock the system up solid when the logo reaches a certain point near the top right hand side.
Once locked the system is completely unresponsive to network or keyboard, only a reset or power cycle will unlock it. Without the logo_saver running the system is as
solid as a rock.

Actions #1

Updated by dillon over 11 years ago

: Hi,
:
: I'm running v2.9.0.68.g57eab-DEVELOPMENT on an M4A78L motherboard
:with a Phenom II 955 (quad core 3.2 GHz), however this has been happening
:for a while but it's only now that I've pinned down the circumstances.
:
: If I have the logo-saver running and displayed on the console then
:anything that generates a high CPU load (make j 8 buildworld in an ssh
:session from another box does nicely) will lock the system up solid when the
:logo reaches a certain point near the top right hand side. Once locked the
:system is completely unresponsive to network or keyboard, only a reset or
:power cycle will unlock it. Without the logo_saver running the system is as
:solid as a rock.
:
:-

:Steve O'Hara-Smith | Directable Mirror Arrays

The syscons console screen saver code in general is a real problem
for us. It's getting hung up on the console spin lock. I think it
is going to be a while before it gets fixed (it won't make the release).
We've whacked a couple of issues related to syscons but not this one
yet.
-Matt
Matthew Dillon
<>
Actions #2

Updated by steve over 11 years ago

On Thu, 28 Oct 2010 14:52:36 -0700 (PDT)
Matthew Dillon <> wrote:

...

The syscons console screen saver code in general is a real problem
for us. It's getting hung up on the console spin lock. I think it
is going to be a while before it gets fixed (it won't make the
release).

Not a big problem - it's not easy to get caught by this one
(I only found it because I started running the box without a monitor and
didn't think about disabling the screen saver).

Actions #3

Updated by tuxillo 3 days ago

  • Description updated (diff)
  • Assignee deleted (0)
Actions #4

Updated by tuxillo 3 days ago

  • Subject changed from System freeze - with logo_saver and high CPU load to System freezes with syscons screen saver on and a high CPU load
  • Status changed from New to Feedback

Could not reproduce it, am I missing something? I tried in a VM, I loaded the module, set a timeout and started a buildworld. The logo was bumping in the sides of the emulated screen and buildworld finished successfully.

We could probably remove the screen savers altogether. I'll leave this opened just in case anybody has something to say.

Actions #5

Updated by steve 3 days ago

Hi,

This happened over eleven years ago on hardware that has long since
vanished. It has very probably been inadvertently fixed over the years.
It's certainly not worth any effort now.

On Sun, 15 May 2022 12:46:52 -0700
wrote:

Issue #1887 has been updated by tuxillo.

Subject changed from System freeze - with logo_saver and high CPU load to
System freezes with syscons screen saver on and a high CPU load Status
changed from New to Feedback

Could not reproduce it, am I missing something? I tried in a VM, I loaded
the module, set a timeout and started a buildworld. The logo was bumping
in the sides of the emulated screen and buildworld finished successfully.

We could probably remove the screen savers altogether. I'll leave this
opened just in case anybody has something to say.

----------------------------------------
Bug #1887: System freezes with syscons screen saver on and a high CPU load
http://bugs.dragonflybsd.org/issues/1887#change-14283

  • Author: steve
  • Status: Feedback
  • Priority: Normal
  • Target version: 6.4
    ----------------------------------------
    Hi,

I'm running v2.9.0.68.g57eab-DEVELOPMENT on an M4A78L motherboard with a
Phenom II 955 (quad core 3.2 GHz), however this has been happening for a
while but it's only now that I've pinned down the circumstances.

If I have the logo-saver running and displayed on the console then
anything that generates a high CPU load (make -j 8 buildworld in an ssh
session from another box does nicely) will lock the system up solid when
the logo reaches a certain point near the top right hand side. Once
locked the system is completely unresponsive to network or keyboard, only
a reset or power cycle will unlock it. Without the logo_saver running the
system is as solid as a rock.

--
Steve O'Hara-Smith <>

Actions #6

Updated by tuxillo 3 days ago

  • Status changed from Feedback to Closed

Hey, thanks for replying :-)

Closing.

Actions

Also available in: Atom PDF