Project

General

Profile

Actions

Bug #2355

closed

panic: rtrequest1_msghandler: rtrequest table error was cpu4, err 17

Added by jaydg almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/27/2012
Due date:
% Done:

10%

Estimated time:

Description

I experimented with wlan and dhcp and had some trouble to get it to work.
To start from scratch, I've deleted the generated interface wlan0 after running /etc/rc.d/netif stop.
At some point after running /etc/rc.d/netif start again this panic occurs. This is reproducible.

Version String: DragonFly v3.1.0.347.g228a6-DEVELOPMENT #4: Mon Mar 19 08:37:17 CET 2012

#0 _get_mycpu () at ./machine/thread.h:69
#1 md_dumpsys (di=<optimized out>) at /usr/src/sys/platform/pc64/x86_64/dump_machdep.c:263
#2 0xffffffff802f9b62 in dumpsys () at /usr/src/sys/kern/kern_shutdown.c:937
#3 0xffffffff802fa1c6 in boot (howto=260) at /usr/src/sys/kern/kern_shutdown.c:387
#4 0xffffffff802fa47d in panic (fmt=0xffffffff805b26a8 "rtrequest1_msghandler: rtrequest table error was cpu%d, err %d\n") at /usr/src/sys/kern/kern_shutdown.c:843
#5 0xffffffff8039d657 in rtrequest1_msghandler (msg=<optimized out>) at /usr/src/sys/net/route.c:815
#6 0xffffffff8039bc70 in rtable_service_loop (dummy=<optimized out>) at /usr/src/sys/net/route.c:205
#7 0xffffffff80305300 in lwkt_deschedule_self (td=<unavailable>) at /usr/src/sys/kern/lwkt_thread.c:362
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

A dump is available.


Related issues 1 (0 open1 closed)

Related to Bug #2402: Showstopper panics for Release 3.2Closedtuxillo08/15/2012

Actions
Actions #1

Updated by sepherosa almost 11 years ago

On Sat, Apr 28, 2012 at 5:38 AM, Joachim de Groot via Redmine
<> wrote:

Issue #2355 has been reported by Joachim de Groot.

----------------------------------------
Bug #2355: panic: rtrequest1_msghandler: rtrequest table error was cpu4, err 17
http://bugs.dragonflybsd.org/issues/2355

Author: Joachim de Groot
Status: New
Priority: Normal
Assignee:
Category:
Target version:

I experimented with wlan and dhcp and had some trouble to get it to work.
To start from scratch, I've deleted the generated interface wlan0 after running /etc/rc.d/netif stop.
At some point after running /etc/rc.d/netif start again this panic occurs. This is reproducible.

Version String: DragonFly v3.1.0.347.g228a6-DEVELOPMENT #4: Mon Mar 19 08:37:17 CET 2012

#0  _get_mycpu () at ./machine/thread.h:69
#1  md_dumpsys (di=<optimized out>) at /usr/src/sys/platform/pc64/x86_64/dump_machdep.c:263
#2  0xffffffff802f9b62 in dumpsys () at /usr/src/sys/kern/kern_shutdown.c:937
#3  0xffffffff802fa1c6 in boot (howto=260) at /usr/src/sys/kern/kern_shutdown.c:387
#4  0xffffffff802fa47d in panic (fmt=0xffffffff805b26a8 "rtrequest1_msghandler: rtrequest table error was cpu%d, err %d\n") at /usr/src/sys/kern/kern_shutdown.c:843
#5  0xffffffff8039d657 in rtrequest1_msghandler (msg=<optimized out>) at /usr/src/sys/net/route.c:815
#6  0xffffffff8039bc70 in rtable_service_loop (dummy=<optimized out>) at /usr/src/sys/net/route.c:205
#7  0xffffffff80305300 in lwkt_deschedule_self (td=<unavailable>) at /usr/src/sys/kern/lwkt_thread.c:362
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

A dump is available.

It will be helpful to have a dump.

Thanks,
sephe

--
Tomorrow Will Never Die

Actions #2

Updated by jaydg almost 11 years ago

I've uploaded the dump on leaf, ~jaydg/crash/2355.

Actions #3

Updated by ftigeot over 10 years ago

  • % Done changed from 0 to 10

I got the same sort of panic on a 24-threads xeon box:
rtrequest1_msghandler: rtrequest table error was cpu16, err 17

Core dump available on leaf:~ftigeot/crash/crash.rtrequest1_msghandler

Actions #4

Updated by ftigeot over 10 years ago

I switched the main ethernet interface from bce0 to ix0:
ifconfig bce0 -alias xxx
ifconfig ix0 192.168.x.x/24

At this point, the default route was gone
As soon as I typed route add default to add it again, the system crashed

Actions #5

Updated by sepherosa over 10 years ago

On Wed, Aug 22, 2012 at 3:24 PM, Francois Tigeot via Redmine
<> wrote:

Issue #2355 has been updated by Francois Tigeot.

% Done changed from 0 to 10

I got the same sort of panic on a 24-threads xeon box:
rtrequest1_msghandler: rtrequest table error was cpu16, err 17

I have checked the jaydg's core, it is crashed on a 6 logic cpu box;
same as yours 24 logic cpu box, i.e. the cpu count is not aligned on
power of 2. Following commit should have fixed it:
271d38c464d5d4591bc37fb66189c6fbc2a6a5be

It could be cherry-picked to 3.0 release branch.

Best Regards,
sephe

Core dump available on leaf:~ftigeot/crash/crash.rtrequest1_msghandler
----------------------------------------
Bug #2355: panic: rtrequest1_msghandler: rtrequest table error was cpu4, err 17
http://bugs.dragonflybsd.org/issues/2355

Author: Joachim de Groot
Status: New
Priority: Normal
Assignee:
Category:
Target version:

I experimented with wlan and dhcp and had some trouble to get it to work.
To start from scratch, I've deleted the generated interface wlan0 after running /etc/rc.d/netif stop.
At some point after running /etc/rc.d/netif start again this panic occurs. This is reproducible.

Version String: DragonFly v3.1.0.347.g228a6-DEVELOPMENT #4: Mon Mar 19 08:37:17 CET 2012

#0 _get_mycpu () at ./machine/thread.h:69
#1 md_dumpsys (di=<optimized out>) at /usr/src/sys/platform/pc64/x86_64/dump_machdep.c:263
#2 0xffffffff802f9b62 in dumpsys () at /usr/src/sys/kern/kern_shutdown.c:937
#3 0xffffffff802fa1c6 in boot (howto=260) at /usr/src/sys/kern/kern_shutdown.c:387
#4 0xffffffff802fa47d in panic (fmt=0xffffffff805b26a8 "rtrequest1_msghandler: rtrequest table error was cpu%d, err %d\n") at /usr/src/sys/kern/kern_shutdown.c:843
#5 0xffffffff8039d657 in rtrequest1_msghandler (msg=<optimized out>) at /usr/src/sys/net/route.c:815
#6 0xffffffff8039bc70 in rtable_service_loop (dummy=<optimized out>) at /usr/src/sys/net/route.c:205
#7 0xffffffff80305300 in lwkt_deschedule_self (td=<unavailable>) at /usr/src/sys/kern/lwkt_thread.c:362
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

A dump is available.

--
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

--
Tomorrow Will Never Die

Actions #6

Updated by marino over 10 years ago

  • Status changed from New to In Progress

Since Sephe thinks this is fixed, let's show some progress on the BR.

Actions #7

Updated by jaydg over 10 years ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF