Project

General

Profile

Actions

Bug #573

closed

DragonFly on Intel Mac?

Added by qhwt+dfly about 17 years ago. Updated almost 17 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Hi.
Although it runs fine on Parallels Desktop(an emulator), it doesn't
with BootCamp. LiveCD stops twirling the baton prematurely.
There's been some good efforts in FreeBSD to install and boot on
MacBook Pro via BootCamp last year, and I confirmed that 6.2-RELEASE
installs and runs almost fine. I searched through their commit log, and
ported the relavant parts (patch attached). MacBook Pro is a legacy-free
hardware and has no keyboard controller, and the patch puts upper limit
on the amount of time to wait for the controller to be ready (or give up),
according to their commitlog.

With this patch, it does boot past the boot loader, but it ends up
in double fault after many lines of 'sched_ithd: stray interrupt 7'.
Also I need to disable acpi driver because it fills the screen with
garbage and I can't see anything in the boot log. I tested cdboot
and the kernel on other PCs and had no problem. So it's probably
safe to commit.

I'm currently playing with it installed in a spare partition of
FreeBSD 6.2-RELEASE installation. The hardest part is that even
on FreeBSD, the keyboard rarely work until the OS boots up (and I saw
this with SuSE too). In fact it's easier edit /boot.config and
/boot/loader.conf from FreeBSD installation than keep punching the
power button :) This may or may not be BootCamp's fault. I hope to post
a few more positive news/patch soon.

Cheers.


Files

a20.patch (4.87 KB) a20.patch qhwt+dfly, 03/06/2007 01:50 PM
a20.patch (6.27 KB) a20.patch qhwt+dfly, 03/11/2007 06:58 AM
Actions

Also available in: Atom PDF