Bug #1181

ACX111 panic

Added by elekktretterr almost 6 years ago. Updated almost 6 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Sorry about the picture size!

I tried to switch from my Atheros(because of the dropouts ive been having)
card back to my ACX111 card. With AMRR enabled, the card is unable to stay
connected to my network(connects and disconnects and keeps retrying). But
when I removed AMRR from the kernel, I get this panic(picture attached).

Verbose dmesg coming soon.

Petr

acx_onoe.JPG (316 KB) elekktretterr, 12/16/2008 11:39 AM

dump80211 (35.7 KB) elekktretterr, 12/16/2008 11:43 AM

dumpradio (85.5 KB) elekktretterr, 12/16/2008 11:43 AM

dmesg.txt Magnifier (35.9 KB) elekktretterr, 12/16/2008 11:43 AM

History

#1 Updated by elekktretterr almost 6 years ago

verbose dmesg, and dumps attached.

Petr

#2 Updated by swildner almost 6 years ago

Could you please put up such big pics and dumps on some external site
next time? It's really a pain in the ass.

Not to mention that embedded pics look like crap in nntp/mail archive
and are pretty much unusable because of that.

Sascha

#4 Updated by sepherosa almost 6 years ago

Mmm, I think I have put MODULE_DEPEND(acx, wlan_ratectl_amrr ...) in
if_acx.c ... You should not remove AMRR from kernel config if you
have acx in the kernel config.
As about using different TX rate control algorithm, you could use:
ifconfig acx0 ratectl onoe

Best Regards,
sephe

#5 Updated by sepherosa almost 6 years ago

On Tue, Dec 16, 2008 at 7:40 PM, Petr Janda
<> wrote:
> verbose dmesg, and dumps attached.

Looks like acx0 never hears assoc-resp form AP. Try putting following
line in your /boot/loader.conf:
hw.acx.enable_pbcc="0"

Best Regards,
sephe

#6 Updated by elekktretterr almost 6 years ago

Hi,
This makes no difference.

Petr

#7 Updated by sepherosa almost 6 years ago

grab

Also available in: Atom PDF