Bug #1428

POSIX.1e implementation is too old

Added by hasso almost 5 years ago. Updated over 4 years ago.

Status:NewStart date:
Priority:LowDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Our posix1e(3) implementation is too old and not compatible with any
recent enough piece of software.

History

#1 Updated by alexh over 4 years ago

afaik posix.1e has been withdrawn some time ago. What software still uses
this? On what implementation do they rely?

Cheers,
Alex Hornung

#2 Updated by hasso over 4 years ago

> afaik posix.1e has been withdrawn some time ago. What software still
> uses this? On what implementation do they rely?

It never left draft status, yes. I don't understand all the relationships
between posix.1e, all different ACL and extended attributes
implementations, but the fact is that ACL's and extended attributes are
supported nowadays filesystems.

But we happen to have sys/extattr.h and friends no thirdparty software
supports. A lot of such software breaks though if it relies only on
existance of headers.

Also available in: Atom PDF