Bug #1533

Installer page faults, amd64, VMware 6.5.2

Added by adamski almost 5 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Tried to install the amd64 iso in VMware 6.5.2 but it always fails at the same
place. Even tried the patched amd64 iso
(http://bugs.dragonflybsd.org/issue1521), same thing happens. The 32-bit iso is
working though.

......
mpt0: <LSILogic 1030 Ultra4 Adapter> port 0x1400-0x14ff mem
0xd8800000-0xd881ffff,0xd8820000-0xd883ffff irq 11 at device 16.0 on pci0
mpt0: MPI Version=1.2.0.0

Fatal trap 12: page fault while in kernel mode
fault virtual address = 0x19
fault code = supervisor read data, page not present
instruction pointer = 0x8:0xffffffff802e0d4d
stack pointer = 0x10:0xffffffff808cab60
frame pointer = 0x10:0xffffffff808cac50
code segment = base 0x0, limit 0xfffff, type 0x1b
= DPL 0, pres 1, long 0, def32 0, gran 1
processor eflags = interrupt enabled, resume, IOPL = 0
current process = 0
current thread = pri 44 (CRIT)
kernel: type 12 trap, code=0
Stopped at mpt_configure_ioc+0x5f1: cmpb $0x10,0x21(%rdx)
db>

History

#1 Updated by sjg over 4 years ago

Is this still the case with a recent snapshot?

#2 Updated by swildner over 4 years ago

Can you provide a backtrace (by typing 't' at the db> prompt) and paste it?

Sascha

#3 Updated by alexh over 4 years ago

imho this is bounce buffer related and should be fixed by now.

Cheers,
Alex Hornung

#4 Updated by swildner almost 2 years ago

  • Status changed from New to Closed
  • Assignee deleted (0)

Closing this. mpt(4) has since been updated numerous times and (afaict) doesn't crash in VMware (at least recent ones). If there are still issues, please reopen.

Also available in: Atom PDF