Bug #2452

sporadic make -j X buildworld failure

Added by sepherosa almost 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:dragonflybsd1% Done:

0%

Category:-
Target version:-

Description

make -j 8 buildworld

on Xeon 3430 (4threads)

--- libc_r.a ---
building static c_r library
rm -f libc_r.a
ar cq libc_r.a `lorder uthread_accept.o uthread_aio_suspend.o
uthread_atfork.o uthread_attr_destroy.o uthread_attr_get_np.o
uthread_attr_init.o uthread_attr_getdetachstate.o
uthread_attr_getinheritsched.o uthread_attr_getschedparam.o
uthread_attr_getschedpolicy.o uthread_attr_getscope.o
uthread_attr_getstack.o uthread_attr_getstackaddr.o
uthread_attr_getstacksize.o uthread_attr_setcreatesuspend_np.o
uthread_attr_setdetachstate.o uthread_attr_setinheritsched.o
uthread_attr_setschedparam.o uthread_attr_setschedpolicy.o
uthread_attr_setscope.o uthread_attr_setstack.o
uthread_attr_setstackaddr.o uthread_attr_setstacksize.o uthread_bind.o
uthread_cancel.o uthread_clean.o uthread_close.o uthread_closefrom.o
uthread_concurrency.o uthread_cond.o uthread_condattr_destroy.o
uthread_condattr_init.o uthread_connect.o uthread_creat.o
uthread_create.o uthread_detach.o uthread_dup.o uthread_dup2.o
uthread_equal.o uthread_execve.o uthread_exit.o uthread_faccessat.o
uthread_fchflags.o uthread_fchmod.o uthread_fchmodat.o
uthread_fchown.o uthread_fchownat.o uthread_fcntl.o uthread_fd.o
uthread_find_thread.o uthread_flock.o uthread_fork.o
uthread_fpathconf.o uthread_fstat.o uthread_fstatat.o
uthread_fstatfs.o uthread_fsync.o uthread_gc.o uthread_getdirentries.o
uthread_getpeername.o uthread_getprio.o uthread_getschedparam.o
uthread_getsockname.o uthread_getsockopt.o uthread_info.o
uthread_init.o uthread_ioctl.o uthread_jmp.o uthread_join.o
uthread_kern.o uthread_kevent.o uthread_kill.o uthread_kqueue.o
uthread_listen.o uthread_main_np.o uthread_mattr_init.o
uthread_mattr_kind_np.o uthread_msync.o uthread_multi_np.o
uthread_mutex.o uthread_mutex_prioceiling.o uthread_mutex_protocol.o
uthread_mutexattr_destroy.o uthread_nanosleep.o uthread_once.o
uthread_open.o uthread_pause.o uthread_pipe.o uthread_poll.o
uthread_priority_queue.o uthread_read.o uthread_readv.o
uthread_recvfrom.o uthread_recvmsg.o uthread_resume_np.o
uthread_rwlock.o uthread_rwlockattr.o uthread_select.o uthread_self.o
uthread_sem.o uthread_sendfile.o uthread_sendmsg.o uthread_sendto.o
uthread_setprio.o uthread_setschedparam.o uthread_setsockopt.o
uthread_shutdown.o uthread_sig.o uthread_sigaction.o uthread_sigmask.o
uthread_sigpending.o uthread_sigprocmask.o uthread_sigsuspend.o
uthread_sigwait.o uthread_single_np.o uthread_sleep.o uthread_socket.o
uthread_socketpair.o uthread_spec.o uthread_spinlock.o uthread_stubs.o
uthread_suspend_np.o uthread_switch_np.o uthread_system.o
uthread_tcdrain.o uthread_unlinkat.o uthread_vfork.o uthread_wait.o
uthread_wait4.o uthread_waitpid.o uthread_write.o uthread_writev.o
uthread_yield.o _atomic_lock.o | tsort -q`
/usr/obj/usr/src/ctools_x86_64_x86_64/usr/libexec/binutils222/elf/nm:
'uthread_accept.o': No such file
/usr/obj/usr/src/ctools_x86_64_x86_64/usr/libexec/binutils222/elf/ar:
uthread_accept.o: No such file or directory
*** [libc_r.a] Error code 1

make: stopped in /usr/src/lib/libc_r
1 error

make: stopped in /usr/src/lib/libc_r
*** [_SUBDIR_all_libc_r] Error code 2

make: stopped in /usr/src/lib
1 error

make: stopped in /usr/src/lib
A failure has been detected in another branch of the parallel make

make: stopped in /usr/src/lib
*** [lib__L] Error code 2

make: stopped in /usr/src
.CURDIR='/usr/src'
.OBJDIR='/usr/obj/usr/src/world_x86_64/usr/src'
.MAKE='make'
MAKE_VERSION='20121010'
LD_LIBRARY_PATH=''
MACHINE_ARCH='x86_64'
MACHINE='x86_64'
MAKEFILE='/usr/src/Makefile.inc1'
.TARGETS='_generic_libs'
.ERROR_TARGET='lib__L'
.ERROR_META_FILE=''
.MAKE.LEVEL='1'
.MAKE.MODE=''
1 error

make: stopped in /usr/src
.CURDIR='/usr/src'
.OBJDIR='/usr/obj/usr/src/world_x86_64/usr/src'
.MAKE='make'
MAKE_VERSION='20121010'
LD_LIBRARY_PATH=''
MACHINE_ARCH='x86_64'
MACHINE='x86_64'
MAKEFILE='/usr/src/Makefile.inc1'
.TARGETS='_generic_libs'
.ERROR_TARGET='lib__L'
.ERROR_META_FILE=''
.MAKE.LEVEL='1'
.MAKE.MODE=''
*** [libraries] Error code 2

make: stopped in /usr/src
.CURDIR='/usr/src'
.OBJDIR='/usr/obj/usr/src/world_x86_64/usr/src'
.MAKE='make'
MAKE_VERSION='20121010'
LD_LIBRARY_PATH=''
MACHINE_ARCH='x86_64'
MACHINE='x86_64'
MAKEFILE='/usr/src/Makefile.inc1'
.TARGETS='libraries'
.ERROR_TARGET='libraries'
.ERROR_META_FILE=''
.MAKE.LEVEL='0'
.MAKE.MODE=''
1 error

make: stopped in /usr/src
.CURDIR='/usr/src'
.OBJDIR='/usr/obj/usr/src/world_x86_64/usr/src'
.MAKE='make'
MAKE_VERSION='20121010'
LD_LIBRARY_PATH=''
MACHINE_ARCH='x86_64'
MACHINE='x86_64'
MAKEFILE='/usr/src/Makefile.inc1'
.TARGETS='libraries'
.ERROR_TARGET='libraries'
.ERROR_META_FILE=''
.MAKE.LEVEL='0'
.MAKE.MODE=''
*** Error code 2
1 error
*** Error code 2
1 error

Best Regards,
sephe

--
Tomorrow Will Never Die

History

#1 Updated by marino almost 2 years ago

Hmmm, I have not seen this and I build with -j8 all the time.
What could the difference be?

#2 Updated by marino almost 2 years ago

More: I used -j8 on both i386 and x86_64 successfully. Does it always happen on libc_r.a ?

#3 Updated by marino almost 2 years ago

  • Assignee set to dragonflybsd1

Is this report still valid?
Or was it caused by dirty /usr/obj directory?

#4 Updated by swildner over 1 year ago

  • Status changed from New to Closed

It is likely due to a dirty source tree in combination with bmake pickyness, which to me looks more like a bug than a feature.

So closing for now. Feel free to re-open if the issue is still observed.

Also available in: Atom PDF