Bug #2679

Running Firefox renders the OS unresponsive

Added by zcrownover 6 months ago. Updated 6 months ago.

Status:NewStart date:06/07/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Userland
Target version:3.8.0

Description

FIrefox worked fine until 3.8, at which point, running it started to lock the system. Clock freezes, keyboard and mouse input ignored, can't get out of X. I don't want to have this make it entirely dismissed as a Virtualbox issue, but this is in Virtualbox on a Mac, version 4.3.12 r93733. At first I thought the error was something just happening once or twice or with certain sites, but even just launching firefox and staying within the settings tabs locked up the system. If you have any ideas for how I can get you better debug information to help with this let me know. I don't have a physical system that I can test this on at the moment.

History

#1 Updated by justin 6 months ago

Is this the same Firefox binary you were running on 3.6, or is it upgraded? Try either going to the newest version if what you have is old, or perhaps vice versa - make a snapshot, and point pkg explicitly at the 3.6 remote directory.

This is a wild guess, not necessarily a helpful guess.

#2 Updated by zcrownover 6 months ago

This is running with the latest binary for 3.8. For what it's worth, I can try specifying the ABI manually in the repo configuration and see if that alone breaks anything while (re)installing firefox. Konqueror seems to crash a lot, but at least it doesn't take everything else down with it. If you have any ideas for me getting some sort of debug information to help I'm up for it. I tried to tee the output from a command line and the file was empty. Kernel messages didn't show anything after I reset the system.

#3 Updated by jorisgio 6 months ago

You should try to get more informations, for instance using vmstat, systat, systat -pv (for token collisions), iostat (for io), top (to check in which state are firefox and X threads). It would help finding the issue. Firefox is working quite well for me, it's slow if i don't renice it, but it does not freeze the whole OS.

Also available in: Atom PDF