Bug #2719

postgresql 9.3 package doesn't install necessary files for a postgresql server

Added by zcrownover 4 months ago. Updated 22 days ago.

Status:ClosedStart date:08/23/2014
Priority:NormalDue date:
Assignee:-% Done:

50%

Category:Userland
Target version:3.8.0

Description

PostgreSQL 9.2 package will install the necessary components for running PostgreSQL, but the 9.3 package doesn't create a /usr/local/pgsql/data directory.

History

#1 Updated by zcrownover 4 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

The 9.2 package runs this but the 9.3 doesn't, I don't know why, but if anyone can fix the package so that it does this automatically that'd be good.

sudo su - pgsql
initdb /usr/local/pgsql/data

If you do that with the 9.3 package you get the data directory that you need. I don't know anything about building pkgng packages though or getting fixes in dports.

I'll mark this as 50% because I think 100% would honestly be if dports and pkg took care of this for the user as they did in the prior version.

#2 Updated by dragonflybsd1 about 1 month ago

Please report dports issues like this to:
https://github.com/DragonFlyBSD/DPorts/issues

That being said, this looks like an issue at the freebsd ports level. E.g. you need to file a PR here instead:
https://bugs.freebsd.org/bugzilla/enter_bug.cgi

#3 Updated by marino 22 days ago

  • Status changed from In Progress to Closed

If this is still an issue, please do one of the actions listed above.

Also available in: Atom PDF