Project

General

Profile

Bug #2971

kernel 4.7: buildworld causes panic: Bad link elm 0xffffffe1c766d500 prev->next != elm

Added by peeter almost 3 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/21/2016
Due date:
% Done:

0%

Estimated time:

Description

The panic happened while doing buildworld. I am not entirely sure that the panic is not caused by a hardware error since prior to the panic two CRC errors showed up in /var/log/messages. On the other hand, it seems they might not be caused by a hardware error since prior to the panic I had seen CRC errors a couple of times and reinstalling the system got rid of them. In more detail, the machine has gone the following cycle of couple of times:

1 - system has a panic (related to the kernel module I'm developing)
2 - hammer checkmap starts reporting errors occasionally
3 - then CRC errors show up /var/log/messages
4 - re-install the system and all errors vanish
5 - go back to 1

However, the last time after step 3 "make buildworld" led to this panic.


Files

hammer-crc-error-crash.txt (9.48 KB) hammer-crc-error-crash.txt peeter, 12/21/2016 03:45 AM

History

#1

Updated by sepherosa almost 3 years ago

I'd suggest to run memtest on your system, I'd suspect bad memory sticks.

On Wed, Dec 21, 2016 at 7:46 PM,
<> wrote:
> Issue #2971 has been reported by peeter.
>
> ----------------------------------------
> Bug #2971: kernel 4.7: buildworld causes panic: Bad link elm 0xffffffe1c766d500 prev->next != elm
> http://bugs.dragonflybsd.org/issues/2971
>
> * Author: peeter
> * Status: New
> * Priority: Normal
> * Assignee:
> * Category:
> * Target version:
> ----------------------------------------
> The panic happened while doing buildworld. I am not entirely sure that the panic is not caused by a hardware error since prior to the panic two CRC errors showed up in /var/log/messages. On the other hand, it seems they might not be caused by a hardware error since prior to the panic I had seen CRC errors a couple of times and reinstalling the system got rid of them. In more detail, the machine has gone the following cycle of couple of times:
>
> 1 - system has a panic (related to the kernel module I'm developing)
> 2 - hammer checkmap starts reporting errors occasionally
> 3 - then CRC errors show up /var/log/messages
> 4 - re-install the system and all errors vanish
> 5 - go back to 1
>
> However, the last time after step 3 "make buildworld" led to this panic.
>
>
> ---Files--------------------------------
> hammer-crc-error-crash.txt (9.48 KB)
>
>
> --
> You have received this notification because you have either subscribed to it, or are involved in it.
> To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

--
Tomorrow Will Never Die

#2

Updated by peeter almost 3 years ago

I ran memtest86 V7.2 from a USB stick and it tested all of the 8GB RAM: so far no errors. I did one pass. Will do another four passes tomorrow when I get back to office.

#3

Updated by peeter almost 3 years ago

Another three passes of memtest86 on 8GB RAM: no errors. Seems RAM is fine.

#4

Updated by liweitianux 4 months ago

  • Status changed from New to Feedback

Hello. Any new findings to this issue?

Buildworld has been run many times on HAMMER, and we haven't gotten another similar issue report. The memory issue suggested by sephe may better explain this issue.

#5

Updated by peeter 4 months ago

Hello

I believe you can close this. I have no means of testing any more, I've long migrated to HAMMER2. Also, DragonFly has undergone many changes since the report.

Cheers

Peeter

--

#6

Updated by peeter 4 months ago

I should note that this was not a memory issue. I tested memory very thoroughly. Also, the system has been running very reliably over the recent 1.5 yrs, definitely not a memory problem.

--

#7

Updated by liweitianux 4 months ago

  • Status changed from Feedback to Resolved

peeter, thank you for providing more information on this issue.

By the way, I've been running DragonFly BSD with HAMMER1 on an old machine for the last ~2 years, and never see such an issue or similar ones.

Also, DragonFly BSD has undergone various major changes since then, so this issue is somewhat irrelevant. Let's close it now.

Cheers,
Aly

Also available in: Atom PDF