Project

General

Profile

Bug #2975

Strange corruption with graphics/darktable and OpenGL

Added by mneumann 7 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/31/2016
Due date:
% Done:

0%


Description

The first time I run "darktable", everything is fine. When I close it, and start it again, it fails with the following error:

ld-elf.so.2: assert failed: /usr/src/libexec/rtld-elf/rtld.c:3045

Signal 0

When I reinstall darktable (pkg remove darktable && pkg ins darktable), and then start it again, it works. But again, the second time, it fails with the same error.

This is my configuration:

DragonFly babel.localnet 4.7-DEVELOPMENT DragonFly v4.7.0.1064.g9294ae-DEVELOPMENT #14: Wed Dec 28 14:45:50 CET 2016
:/usr/obj/usr/src/sys/X86_64_GENERIC x86_64

I am using radeonkms. Is something corrupting my memory? Maybe OpenGL?

History

#1 Updated by mneumann 7 months ago

It must be related towards OpenCL. When I reinstall darktable, I can run it with "darktable --disable-opencl" as often as I want.

#2 Updated by zrj 7 months ago

mneumann wrote:
> It must be related towards OpenCL. When I reinstall darktable, I can run it with "darktable --disable-opencl" as often as I want.

Do you have lang/clover installed? If so darktable is not gracefully handling opencl invocation. In current DRM driver implementation we do not support /dev/dri/renderD128+ nodes that do not require X11 authentication (mesa developers removed x-cookie verification from clover and to add it back is not so trivial). We could add /dev/dri/control and /dev/dri/render nodes into drm.ko (technically we should anyway) but that would open up a very likely security hole. Given how most of c++ programs deal with OpenCL contexts we would also need swapable drm/ttm buffer memory too and that is another story.
If it is lang/beignet on i915, just don't use it.

#3 Updated by mneumann 7 months ago

Update: The failures seem to be pretty random, so "darktable --disable-opencl" does not work as described above, it just did work for a few times, so I assumed this was related. No, I don't have lang/clover installed. I am using a Radeon card. I will wait for the new version of darktable and try again. They have fixed some issues. I was just very curious, why "pkg remove" made it work again, but now I can't even reproduce that.

#4 Updated by mneumann 7 months ago

Same problem happens with darktable 2.2.1.

#5 Updated by ftigeot 7 months ago

For what it's worth, darktable on an i915 Haswell system immediately dies with this error:
ld-elf.so.2: assert failed: /usr/src/libexec/rtld-elf/rtld.c:3045

#6 Updated by mneumann 7 months ago

good to know. so it isn't related to radeon at all then. it's the same error I am getting.

Also available in: Atom PDF