Bug #879

Page fault when booting an old Pentium machine

Added by tuxillo almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:TGEN% Done:

0%

Category:-
Target version:-

Description

Hello

Today I installed DragonflyBSD on a old Pentium I 75Mhz with 32MB EDO RAM
to see what happens. I first installed harddisk on another machine, when
DF installation procedure ended I installed the harddisk on that old
machine :P

And what happened is that it doesn't boot at all :-(

It throws a Fatal Trap 12: page fault while in kernel mode and the boot
process stops

I have uploaded some pictures to leaf so you can see more detailed
information.

http://leaf.dragonflybsd.org/~tuxillo/bugs/

If you need some more information, let me know.

Cheers
Antonio Huete

History

#1 Updated by wa1ter almost 7 years ago

On Fri, 7 Dec 2007, Antonio Huete wrote:

That *is* an old one. What cpu options did you build the kernel with:

platform pc32
machine i386
machine_arch i386
cpu I486_CPU
cpu I586_CPU
cpu I686_CPU

BTW, I thought i386 support had been ripped out already, am I wrong
about that?

#2 Updated by tuxillo almost 7 years ago

El Fri, 07 Dec 2007 12:43:13 -0800, walt escribió:

Hello Walt
I didn't build the kernel since it's a clean install. AFAIK Pentium I
cpus are I586, correct me if I'm wrong.

About i386 support, I'm not sure whether it was removed.

Cheers

#3 Updated by swildner almost 7 years ago

No you're not. I386_CPU was removed.

machine/machine_arch are more related to the x86 architecture.

Sascha

#4 Updated by wa1ter almost 7 years ago

Right. It was supposed to be named the 586 but trademark lawyers nixed
that idea.

Well, no one else is asking questions yet, so I'll ask some random ones.

Have you tried booting with ACPI disabled? (See the DragonFly boot
menu.) Do you have LBA enabled in your BIOS? Does the machine have
a CDROM or even a floppy disk drive? You might try booting the install
disks from FreeBSD or NetBSD or Knoppix just to see what happens.

Oh, and did you try booting that hard disk in the original machine you
used to install DFly?

#5 Updated by tuxillo almost 7 years ago

El Fri, 07 Dec 2007 14:47:40 -0800, walt escribió:

When booting DragonFly I have tried all the options in the menu, but no
one of them succeed, I keep getting same error. This BIOS is too old, it
doesn't have LBA. Machine doesn't have neither CDRom nor floppy drive and
the BIOS doesn't leave me the choice of booting from CD.
Dragonfly booted fine on the Pentium II I installed.

If you need some more information, please let me know :)
Cheers
Antonio Huete

#6 Updated by TGEN almost 7 years ago

As said on IRC, please try the patch at
http://leaf.dragonflybsd.org/~tgen/nata_dma.diff .

#7 Updated by TGEN almost 7 years ago

Fix committed.

#8 Updated by tuxillo almost 7 years ago

El Sat, 08 Dec 2007 20:46:58 +0000, Thomas E. Spanjaard escribió:

Hello again :)

That patch worked perfect for this case. Anyways, I keep receiving some
"errors" in dmesg. I have included a dmesg output and a pciconf output.

I have moved all info related this bug into another folder. You can now
access everything on:

http://leaf.dragonflybsd.org/~tuxillo/bugs/nata_dma/

Thank you very much for your support.
Cheers
Antonio Huete

#9 Updated by TGEN almost 7 years ago

This issue has been resolved, please open another issue instead.

Also available in: Atom PDF