Bug #892

Two questions about sendmail(8)

Added by frank about 7 years ago. Updated almost 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

I have encountered unexpected difficulties with sendmail (on both HEAD and
1_10_Slip). Possibly I have missed something new, I'm not sure if all this
is a bug. First, is the well-known method to rebuild sendmail, i.e.,

cd /usr/src/usr.sbin/sendmail
make cleandir
make obj
make

still supposed to work? If so, there is problem linking the binary:
---
cc: /usr/src/lib/libsmutil/libsmutil.a: No such file or directory
*** Error code 1

Stop in /usr/src/usr.sbin/sendmail.
---

Secondly, sendmail 8.14.x refuses connections from hosts in the local net.
Messages from localhost are processed normally, but a connection from a
remote host only gives a syslog message like this:
---
Dec 20 18:19:00 <hostname> kernel: pid 63229 (sendmail), uid 0: exited on signal 11
---
For example, it is sufficient to do a 'nc -z <hostname> 25' on a remote
machine to get this. The same can be observed for sendmail 8.14.2 from
pkgsrc. On the other hand, sendmail 8.13.8 (from pkgsrc) with the the
identical(!) mailer configuration has no problems at all and shows normal
operation. Any idea what's going wrong here?

Regards,
Frank Josellis

History

#1 Updated by swildner about 7 years ago

It seems that sendmail needs lib/libsm and lib/libsmutil built previously.

Sascha

#2 Updated by frank about 7 years ago

What make me curious is that these libs are apparently expected to be
found under /usr/src/..., not /usr/obj/... The path looks strange to me.

Regards,
Frank

#3 Updated by swildner about 7 years ago

Hmm,

I just tried.

The following sequence works here:

cd /usr/src/lib/libsm
make obj
make
cd ../libsmutil
make obj
make
cd ../../usr.sbin/sendmail
make obj
make

Sascha

#4 Updated by frank about 7 years ago

Having again the possibility to rebuild sendmail, I could do another test.
On the 1.10 box I had 'CCVER?=gcc41' set in /etc/make.conf, and this has
now been reset to the default. The sendmail 18.4.1 excutable built with
gcc 3.4.6 doesn't show the described behavior and relays my mail just as
desired. So the compiler is apparently involved.

Regards,
Frank

#5 Updated by hasso almost 6 years ago

Is it still the case?

#6 Updated by frank almost 6 years ago

On Tue, 20 Jan 2009, Hasso Tepper (via DragonFly issue tracker) wrote:

No, it's solved. As far as I remember some sendmail fixes were committed
in early 2008, and the signal 11 + coredump issue I had observed was
obviously a related to this.

Regards,
Frank Josellis

#7 Updated by swildner almost 6 years ago

Problem solved according to OP.

#8 Updated by swildner almost 6 years ago

close

Also available in: Atom PDF