Project

General

Profile

Actions

Bug #2927

closed

e2a21467e1 Updates to show "4.7" and other changes to major headers should be temporarily suspended

Added by davshao over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
07/20/2016
Due date:
% Done:

100%

Estimated time:

Description

commit 5d920ec6b97613f06aba4a09bfb91413b1fd93c3 Fix excessive ipiq recursion (2)
does not correct the problem I have observed on at least two machines that

make -j7 buildworld

locks up the machine. (When using make buildworld I move /usr/obj/usr to start the build from scratch.) On one machine there seems to be a reproducible lock up at

sh /usr/src/tools/install.sh -o root -g wheel -m 555 lto1 /usr/obj/usr/src/ctools_x86_64_x86_64/usr/libexec/gcc50

Changes to major headers should be temporarily suspended until this problem is resolved, because I have observed that even

make quickworld

can fail to complete without lockup. Someone using UFS as their filesystem may experience quite substantial filesystem corruption after a lockup. By limiting changes to major headers, this gives the greatest chance of a successful make quickworld when this problem is finally resolved.

Actions

Also available in: Atom PDF