Bug #2655

mounting devfs at boot hangs on Lenovo T60p

Added by eradman 5 months ago. Updated 3 months ago.

Status:FeedbackStart date:03/15/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Kernel
Target version:3.6.1

Description

I downloaded the dfly-i386-3.6.1_REL.img and copied to a USB flash drive. It appears to boot my IBM/Lenovo T60p until this message appears:

mounting devfs

Then it hangs. If I press the power button it gracefully shuts down, but it won't proceed.

Attached is the dmesg from OpenBSD 5.5-current which I'm currently running

t60p.dmesg (7.04 KB) eradman, 03/15/2014 07:29 PM

History

#1 Updated by eradman 5 months ago

  • Category changed from Bugtracker to Kernel

#2 Updated by eradman 5 months ago

I think this relates somehow to the fact that I have a SSD installed in the Ultrabay slot instead of the CD/DVD drive.

When I eject the disk it continues. Once the login prompt appears it hangs again until I put the drive adaptor back in

#3 Updated by eradman 4 months ago

Also tried 3.6.2/x86_64 this an another T60p what has the T7200 processor. Booting from USB or the CD it hangs at "mounting devfs"

#4 Updated by eradman 4 months ago

Also tried 3.0.3 with the same result.

#5 Updated by swildner 3 months ago

What does it say when you send it SIGINFO (hit CTRL-T) while it is hanging after "mounting devfs"?

#6 Updated by Johannes.Hofmann 3 months ago

FWIW I have dfly running on a T410s with SSD in the ultrabay without issues.

#7 Updated by eradman 3 months ago

Ctrl-T shows

load: 0.16 cmd: sh 3 [running] 0.00u 0.10s 2% 704k

#8 Updated by tuxillo 3 months ago

  • Status changed from New to Feedback

Hi,

Please set:

rc_debug="YES"

in your /etc/rc.conf for a detailed view of what's starting up. Make that output available somewhere, if you can't find yourself where it is hanging.

Best regards,
Antonio Huete

#9 Updated by eradman 3 months ago

Can I set this option at the boot loader? (I'm booting off of the USB install image)

#10 Updated by swildner 3 months ago

On Fri, 16 May 2014 15:59:36 +0200,
<> wrote:

> Issue #2655 has been updated by eradman.
>
>
> Can I set this option at the boot loader? (I'm booting off of the USB
> install image)

It has to be set in /etc/rc.conf. The USB image is r/w so if you get it to
the login prompt somehow, you can login as root and just normally edit
/etc/rc.conf to add it.

#11 Updated by eradman 3 months ago

I was able to boot from USB on a Dell laptop and edit /etc/rc.conf. Now when I boot it on my T60 it hangs at the same place with no additional output that I can see.

Also available in: Atom PDF