Bug #2269

Panic on KKASSERT((c->c_flags & (CALLOUT_PENDING|CALLOUT_ACTIVE))

Added by masterblaster over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:01/06/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

On v2.13.0.784.gc1745-DEVELOPMENT, x86_64

#0 _get_mycpu () at ./machine/thread.h:69
#1 md_dumpsys (di=<optimized out>)
at /usr/src/sys/platform/pc64/x86_64/dump_machdep.c:263
#2 0xffffffff802bd915 in dumpsys () at /usr/src/sys/kern/kern_shutdown.c:925
#3 0xffffffff802bdf7b in boot (howto=260)
at /usr/src/sys/kern/kern_shutdown.c:387
#4 0xffffffff802be232 in panic (
fmt=0xffffffff8051bdf0 "assertion \"%s\" failed in %s at %s:%u")
at /usr/src/sys/kern/kern_shutdown.c:831
#5 0xffffffff802dbeb7 in callout_stop_sync (c=0xffffffe065c82990)
at /usr/src/sys/kern/kern_timeout.c:519
#6 0xffffffff802dadd0 in sys_setitimer (uap=0xffffffe066028b68)
at /usr/src/sys/kern/kern_time.c:762
#7 0xffffffff804de981 in syscall2 (frame=0xffffffe066028c18)
at /usr/src/sys/platform/pc64/x86_64/trap.c:1248
#8 0xffffffff804c806b in Xfast_syscall ()
at /usr/src/sys/platform/pc64/x86_64/exception.S:323
#9 0x000000000000002b in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Get dump from https://84.73.12.43/crash/core25.txz

I'm still experiencing regularly issue 2092, it could be related to it as ahci_ata_cmd_done() calls callout_stop_sync() (which panic comes from)

History

#1 Updated by isenmann over 2 years ago

Since the upgrade from 2.12 to master last friday, I see this panic:
assertion "(c->c_flags & (CALLOUT_PENDING|CALLOUT_ACTIVE)) == 0"
failed in callout_stop_sync at /usr/src/sys/kern/kern_timeout.c:519
regularly.

Have just seen this panic again after an update to v2.13.0.964.g2c5c4
and about 1h uptime.

#2 Updated by dillon over 2 years ago

:Issue #2269 has been updated by G. Isenmann.
:
:Since the upgrade from 2.12 to master last friday, I see this panic:
:assertion "(c->c_flags & (CALLOUT_PENDING|CALLOUT_ACTIVE)) == 0"
:failed in callout_stop_sync at /usr/src/sys/kern/kern_timeout.c:519
:regularly.
:
:#5 0xffffffff802dbeb7 in callout_stop_sync (c=0xffffffe065c82990)
: at /usr/src/sys/kern/kern_timeout.c:519
:#6 0xffffffff802dadd0 in sys_setitimer (uap=0xffffffe066028b68)
: at /usr/src/sys/kern/kern_time.c:762
:
:Get dump from https://84.73.12.43/crash/core25.txz

Thanks for the dump. I've committed what I believe should be a
workable fix for the callout race being run from the itimer.

commit 7881367cc47b64348df063a9c6962909d1f1eb71

:I'm still experiencing regularly issue 2092, it could be related to it as ahci_ata_cmd_done() calls callout_stop_sync() (which panic comes from)

This is a more difficult problem. I have committed what I believe
should fix the problem but you need to test it.

commit bb79834d4440c42ded824722460ae008a58ecf26

Please try updating to the latest master ('git log' in /usr/src to
make sure you got both commits), and continue testing.

At the moment you seem to be able to reproduce these bugs the quickest
so please get back to us as to whether the commits fixed one or both
problems.

Thanks for the bug report!

-Matt
Matthew Dillon

#3 Updated by isenmann over 2 years ago

The dump was from Magliano Andrea, but I have seen this panic on one
system at home six times last week.

No panic over the weekend with the latest master. Will again put some
load on this machine, when I get home today.

#4 Updated by isenmann over 2 years ago

No panic last night.

#5 Updated by alexh about 2 years ago

  • Status changed from New to Feedback

#6 Updated by isenmann about 2 years ago

Haven't seen this panic with above fix, while using the affected system regularly during the last five weeks.

#7 Updated by alexh about 2 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF