Bug #179

Cannot boot with SMP and APIC_IO in kernel conf

Added by rumcic over 8 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

I have been unable to get to a login prompt (to boot up) my dragonfly bsd
installation if I compile a kernel with both SMP and APIC_IO options.

Since it can't boot up, I can only provide pics i took with my phone of what
happens during boot up, they are at http://www.rumko.net/dragonfly/ and so is
the kernel config file.

Hope someone can fix my problem.

History

#1 Updated by elekktretterr over 8 years ago

I believe thats because your motherboard's BIOS is quite broken. Some
suggestions: 1) Update your BIOS 2) Turn of APIC_IO

Regards

Petr Janda

#2 Updated by dillon over 8 years ago

:I have been unable to get to a login prompt (to boot up) my dragonfly bsd
:installation if I compile a kernel with both SMP and APIC_IO options.
:
:Since it can't boot up, I can only provide pics i took with my phone of what
:happens during boot up, they are at http://www.rumko.net/dragonfly/ and so is
:the kernel config file.
:
:Hope someone can fix my problem.

Its hard to tell but I think it may be crashing in this bit of code
in ad_timeout():

/* if retries still permit, reinject this request */
if (request->retries++ < AD_MAX_RETRIES) {
ad_requeue(adp->device->channel, request);
}
else {
/* retries all used up, return error */
request->bio->bio_buf->b_error = EIO; <<<<<<<<<<<<<<<<<<<<< HERE
request->bio->bio_buf->b_flags |= B_ERROR;
devstat_end_transaction_buf(&adp->stats, request->bio->bio_buf);
biodone(request->bio);
ad_free(request);
}
ata_reinit(adp->device->channel);

I'm not sure why, though. But that isn't the cause of the problem...
the ATA timeout code may be broken in some way, but a timeout can
only occur in that manner (theoretically) if interrupt routing isn't
working, so it is possible that APIC routing is broken in some way.

The fault address is really weird. It kinda looks to me like the
BUF/BIO was free()'d up prior to the ad_timeout() and the memory was
being used for something else (like to hold text).

What kind of machine is this? Motherboard and chipset?

-Matt
Matthew Dillon
<>

#3 Updated by elekktretterr over 8 years ago

> How safe would it be to use wine on the winflash utility from DFI?

Safe if you DONT like your computer. I find that a lot of manufacturers
provide either a bootable floppy disk to update your BIOS, or they provide
floppy image of the new BIOS and tell you to use a Windows boot disk, like
Intel does. Is your motherboard manufacturer like that? Worst case scenario,
you'll have to install Windows.

#4 Updated by tuxillo over 5 years ago

Hi,

About the first point, saying it is not booting with SMP and APIC_IO, I want to
say that, although APIC_IO is somehow broken on many systems, Sephe did a great
work on SMP some months ago. Is it possible for you to try with latest ISO snapshot?

Regarding the second about flashing the BIOS, I think you can use a MSDOS
bootdisk for that. There is a ton of links out there that provide those:
http://www.google.es/search?hl=es&amp;client=firefox-a&amp;channel=s&amp;rls=org.mozilla%3Aes-ES%3Aofficial&amp;hs=luZ&amp;q=msdos+boot+disk+images&amp;btnG=Buscar&amp;meta=

Cheers,
Antonio

#5 Updated by ahuete.devel over 5 years ago

By "not usable at all" you mean by no OS different from Windows?

2009/8/26 Hasso Tepper <>:
>> About the first point, saying it is not booting with SMP and APIC_IO, I
>> want to say that, although APIC_IO is somehow broken on many systems,
>> Sephe did a great work on SMP some months ago. Is it possible for you
>> to try with latest ISO snapshot?
>
> There are systems which don't have any usable mptable at all, therefore
> can't boot anyway with APIC_IO option. As example of such mptable:
>
> http://leaf.dragonflybsd.org/~hasso/mptable-intel-DQ965GF.txt
>
>
> --
> Hasso Tepper
>

#6 Updated by hasso over 5 years ago

> About the first point, saying it is not booting with SMP and APIC_IO, I
> want to say that, although APIC_IO is somehow broken on many systems,
> Sephe did a great work on SMP some months ago. Is it possible for you
> to try with latest ISO snapshot?

There are systems which don't have any usable mptable at all, therefore
can't boot anyway with APIC_IO option. As example of such mptable:

http://leaf.dragonflybsd.org/~hasso/mptable-intel-DQ965GF.txt

#7 Updated by rumcic about 3 years ago

  • Description updated (diff)
  • Status changed from New to Resolved

Fixed long ago

#8 Updated by rumcic about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF